PAC-ROM logo
  • ¡Welcome to the PAC-ROM Forum!
  • Don't forget to follow us on Google+, Facebook, or Twitter!
  • Hi , Your primary usergroup is: Guests
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating from 4.3 to 4.4
#1
Exclamation 
So... Right now I have PAC 4.3.Build1 flashed.
I checked today, and saw that a new version was released, the 06.03.2014.

Now, I went into my recovery (TWRP v2.5.0.0) and tried flashing it. (no factory reset, cuz it's an update, right?). But every time I tried, it glitches out on me.

Now, I don't want to do a factory reset (cuz I have various important data on my phone), so I wanted to ask if there were any fixes/reason why I get this problem.

If it wasn't clear - I confirm that I have a Nexus 4. 

Recovery log:

-Formatting system
-Extracting system files...
-Making symlinks
-set_metadata_recursive: some changes failed
-E:Error executing updater binary in zip '/sdcard/Download/pac_mako-nightly-20140306.zip'
-Error flashing zip '/sdcard/Download/pac_mako-nightly-20140306.zip'
-Updating partition details...
 
Reply
#2
(03-06-2014, 08:58 PM)ElfenSky Wrote: So... Right now I have PAC 4.3.Build1 flashed.
I checked today, and saw that a new version was released, the 06.03.2014.

Now, I went into my recovery (TWRP v2.5.0.0) and tried flashing it. (no factory reset, cuz it's an update, right?). But every time I tried, it glitches out on me.

Now, I don't want to do a factory reset (cuz I have various important data on my phone), so I wanted to ask if there were any fixes/reason why I get this problem.

If it wasn't clear - I confirm that I have a Nexus 4. 

Recovery log:

-Formatting system
-Extracting system files...
-Making symlinks
-set_metadata_recursive: some changes failed
-E:Error executing updater binary in zip '/sdcard/Download/pac_mako-nightly-20140306.zip'
-Error flashing zip '/sdcard/Download/pac_mako-nightly-20140306.zip'
-Updating partition details...

4.3 - 4.4 is not just an update, you have to factory reset


Sent from my ST18i using Tapatalk
Device Honami | ROM PAC-5.1 | Kernel M5
Device Urushi | ROM PAC-5.0 | Kernel LegacyXperia | Retired
 
Reply
#3
Update TWRP. I just flashed KK over JB and it was fine, but WiFi didn't work as expected.

Sent from my SAMSUNG-SGH-T989 using Tapatalk
Using Tapatalk
 
Reply
#4
(03-07-2014, 12:48 AM)ryh Wrote: Update TWRP. I just flashed KK over JB and it was fine, but WiFi didn't work as expected.

Sent from my SAMSUNG-SGH-T989 using Tapatalk

Thanks! I had to do a quick search about how to update it (GooManager method wasn't working) and found on XDA that I was not the only one and that old versions in general had problems running 4.4 scripts.

Problem solved, I updated TWRP and was able to flash the latest nightly no problem. +1

source 1
source 2
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)