PAC-ROM logo
  • ¡Welcome to the PAC-ROM Forum!
  • Don't forget to follow us on Google+, Facebook, or Twitter!
  • Hi , Your primary usergroup is: Guests
Hello There, Guest! Login Register


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SystemUI force close loops on SOME galaxy S4 devices
#1
I own a international Galaxy S4, and have tried several builds of PAC both by [vertigo] and metaIIica from XDA-dev forums.
It appears that, sooner or later, SOME devices (not all, since the builders themselves cannot reproduce the problem) incur in a SystemUI crash, which loops indefinitely each time the process is restarted. This doesn't stop by rebooting the device, nor by clearing cache and data of SystemUI.apk, or flashing the ROM over itself... only way to get rid of it is by doing a fullwipe (until next occurrence).
Only some people (hence, devices) are affected, and all of them, me included, have flashed the ROM with the suggested method (official latest CWM recovery, format /system, and so on).

The SystemUI FC loops just happens... it doesn't seem to be triggered by anything special, it usually pops up on new installations by changing the UI preferences (those that require the status bar to restart), because on a new installation you usually mess with every option and restart status bar often... but even if you do not make any change at all to the status bar, sooner or later you (if on an affected device) stumble upon the problem, since SystemUI gets basically restarted each time you reboot the phone.
So, on a reboot, even if the process worked perfectly in the previous run, you may get a FC loop right after boot, and then you're doomed.

Here is a logcat of several FCs one after the other: <!-- m --><a class="postlink" href="http://pastebin.com/NqzFmpj2">http://pastebin.com/NqzFmpj2</a><!-- m -->

Please let me know how I can help, I would really like to be able to use this ROM on my device.
 
Reply
#2
same problem here
 
Reply
  


Forum Jump:


Browsing: 1 Guest(s)